By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by Allendale Jan 24th

VFD/Lathe fault

All Topics | Latest Posts

Search for:  in Thread Title in  
Ron Laden06/07/2020 15:30:53
avatar
1970 forum posts
390 photos

I ran into a problem this morning with the lathe.

I used it and all was as normal switched it off and went back to it later, on switching the lathe on the chuck started up even though the speed control (remote pot) was at zero. The VFD (Jaguar Cub) was showing 34.6, I could wind the pot to the top end and get the usual max of 50 but I couldnt get it down below 34.6 and stop the drive even with the pot at the zero/off position.

I am not too good at electrics but for some reason suspected the pot, took the cover off the control box and found the ground wire to the pot had become un-soldered. Thinking that was the fault I re-soldered the wire and tried again but still had the same problem. I went through the manual trouble shooting (what bits I could understand) but didnt find much help there. I also have a basic settings guide that came with the lathe from the VFD supplier when the previous owner installed the drive. I checked through the parameters, though I dont understand what some of them do and they seemed good to the guide.

Now when I power up the VFD I get a reading of 0.00 but there seems to be no communication between VFD and the remote control panel, fwd/rev switches, the on/off switches and the speed control pot are all doing nothing. When I checked the parameters I did get in a bit of a muddle at one point so dont know if I have switched something off or not, cant say.

Not very helpful I know but wondered if anyone can suggest what the problem may be or suggest any settings that need checking.

Thanks

Ron

John Hinkley06/07/2020 16:09:57
avatar
898 forum posts
298 photos

Ron,

I don't know whether this will help as my VFD is a HuangYang one, not Jaguar, but I think a lot of them share the same or similar parameters. When I fitted a 3-phase motor to my mill, I used the following parameter settings. Note: you have to set param001=1 to tell the VFD to accept external control - maybe you reset it to zero by mistake? I doubt you have changed the jumper pins referred to.

I made a note of what I did, just in case:

Bear in mind this is for my HY01D523B 1.5kW 2HP vfd.
1. set the V1 - VR jumper to short pins 1 and 2. For external pendant control
2. Set Parameter 013 ( Pd013 ) = 8 Factory reset to start with all default settings.
3. Set Pd001 = 1 Select external control
4. Set Pd002 = 1 Speed control by external potentiometer
5. *Set Pd005 = 400 Maximum operating Hz
6. *Set Pd004 = 50 Base Hz
7. *Set Pd003 = 400 Main Hz
8. Set Pd144 = 1420 Rated motor rpm from motor plate
9. Set Pd014 = 10 Acceleration to speed in secs
10. Set Pd015 = 10 Deceleration time to stop in secs
11. Set PD072= 120Hz (default is 50 Hz)
12. Set Pd141 = 220 Motor rated voltage from motor plate
13. Set Pd142 = 7 Motor rated current from motor plate
Items 5/6/7 * must be done in that order. I don't know why but the manufacturer is
specific on that point.

Hope that at least gives you a start.

John

Craig Brown 206/07/2020 16:15:50
21 forum posts
8 photos

Hi Ron

Your initial problem is almost as if your minimum speed/frequency parameter has changed from 0 to 34.6, or like you say your pot has gone duff (their functionality can be tested with a multimeter).

For you to have now lost your remote controls it could be that some parameters have changed. If you could post a picture of the parameter information you have then it may help to pin point which ones may need checking.

As an aside, we lost all parameters on a drive at work once and the only backup we had was an old print out. We had to go through all 999 parameters changing what ever needed changing.

Let's hope your issue is a much more simple fix

fastdave06/07/2020 16:21:01
avatar
28 forum posts

Hi Ron, Dave from Fife, Scotland here,

I googled your VFD, and from what I can make out of the download manual, there is a minimum frequency setting, but you would have to go into programming mode to find it - the downloads I got were the first offerings of the google search engine, not terribly sure if they were easy to follow.

I got this from the manual - (7) A frequency command with higher priority than the one attempted was active. Check the higher priority run command with Menu #2 "Datachecking" and Menu #4 "I/O checking" using the keypad,referring to the block diagram of the drive command generator.Î Correct any incorrect function code data settings (e.g.cancel the higher priority run command). (8) The upper and lower frequencies for the frequency limiters were set incorrectly. Check the data of function codes F15 and F16. Î Change the upper and lower frequencies (F15 and F16) tothe correct ones. (9) The coast-to-stop command was effective. Check the data of function codes E01, E02, E03, E98 and E99with Menu #2 "Data checking" and the input signal status withMenu #4 "I/O checking" using the keypad. Î Release the coast-to-stop command setting.

fastdave06/07/2020 16:21:32
avatar
28 forum posts

Otherwise, there may be an unfixable fault, for they are pretty reliable. - I just got the one below - for about £70.00, and I'm delighted with it - I'm using it on a 1.5 Kw motor, wired direct in star, although it accepts Delta, I just wired it in as I had connected the motor to a 3 PH convertor, and that gives me speed control, reverse/forward, and by extrapolation, speed from the frequency displayed (directly proportional).

I tell you this because I think, like your Telly, it will be uneconomical to repair.

You speak of a control panel - I wonder why you would need this, or is it the one on the VFD? for this has all the controls you would need to connect directly.

Please remember ( I know the 'manual' comes with a fifty page Health and safety document), these supplies (VFD) carry heavy voltages for some time after switch off - so leave it plugged in for 5 mins or so before unplugging and doing anything to it

Single phase 220V 2.2KW 5HP best VFD Inverter Frequency Converter Converter VFD  

Edited By JasonB on 06/07/2020 16:23:55

SillyOldDuffer07/07/2020 10:02:36
5924 forum posts
1281 photos

Oh dear!

I'd approach this one methodically, because it's likely there are two faults.

I think the first thing to do is check the pot is working correctly with a multimeter. The pot's ground wire being disconnected, and it still sort of worked, means the all the connections from the control panel to the VFD need to be checked. Photos would help!

Back to the pot. One end is connected to a DC source (5 or 12V) provided by the VFD, the other to a particular ground terminal on the VFD. This isn't necessarily the same as mains earth. The pot's wiper (middle connection) puts a voltage varying from DC max to DC zero on to the VFD's speed control terminal.

Confirm the pot alters the speed control volts at the terminal before doing anything else. Any hint of misbehaviour replace the pot - they are vulnerable to dirt and wear and tear. (Squirting them with switch cleaner can get them going again. Good with dirt, not with wear.)

Important to ensure the control wiring is working before reconfiguring the VFD. Messing with the VFD's internals in hope of fixing a wiring problem is likely to replace one problem with two!

However, after confirming all the connections are solid (vibration can loosen them), if it's still not working, next step is to restore the VFD's sanity.

Running the VFD from it's own control panel (if there is one) may show helpful error codes, and working OK from the back but not from the remote pendant suggests the pendant or it's connections are adrift,.

If looking at the settings doesn't highlight anything wrong, the usual procedure is to reset the unit back to factory settings (how to varies and should be in the manual), and then manually restore your local settings. This can range from difficult to easy depending on the VFD. New VFD's aimed at people like us often come sensibly preconfigured, and relatively few options. High end industrial VFDs, especially older ones, are installed by trained men, made familiar with the options and how to read the manual on a course. A very common arrangement is for these settings to be configured in an office by an expert and then copied directly to the machine. Fat lot of use that is to us!

Not sure about the Jaguar - my feeling is it's in the middle, fairly user friendly but with plenty of confusing choices.

Ron said 'Now when I power up the VFD I get a reading of 0.00 but there seems to be no communication between VFD and the remote control panel, fwd/rev switches, the on/off switches and the speed control pot are all doing nothing. When I checked the parameters I did get in a bit of a muddle at one point so dont know if I have switched something off or not, cant say.' One possibility is the pendant is disconnected, check the wiring. The other is the VFD has been put into local control, in which case it should be possible to work it from that end.

As the problem started with a speed control problem, which may have been related to the disconnected wire, I think the VFD is probably OK, though it may have been confused by Ron.

Basically the diagnostic approach is to check everything step by step, make sure all the connections are physically correct, then confirm electrical continuity, then look at the VFD. Two different problems being in play at the same can confuse diagnosis; don't get disheartened! The forum is invaluable, with luck an easy answer, more often helping navigate the maze.

Worst case the VFD and pendant can be replaced. Probably isn't necessary, touch wood!

Dave

Ron Laden07/07/2020 10:16:36
avatar
1970 forum posts
390 photos

Thanks for the advice guys,

A quick update, last evening I went through all the F codes (fundamental functions) and found a couple of incorrect settings, rectified those and I know have control back at the panel.

With the motor switched off I dialled the speed control pot back and forth and the VFD readout went from 0 to 50 Hz as normal so I wonder does that show the potentiometer is ok..? However with the motor switched on and starting at zero I had drive which I could adjust from 0 up to around 80 rpm at about 20% of the pot travel but going past 20% the speed went up to 170 rpm and no more regardless of where I had the pot position. The VFD readout was frantically dancing around between 9.0 and 10.5 Hz and the motor sounded to be hunting and was noisy compared to what it normally is.

So do I have an incorrect setting somewhere but if I do where..? or is the pot ok with the motor off but breaking down under load with the motor on..? I would like to think it is more of a setting problem but I dont know... any suggestions appreciated guys.

A picture below of the VFD and the control panel I have on the lathe, Dave you asked why a control panel, well its how the lathe came and the controls sitting just above the headstock is very convenient.

img_20200707_072426.jpg

img_20200707_072459.jpg

Ron Laden07/07/2020 10:20:35
avatar
1970 forum posts
390 photos

Hi Dave (SOD)

Our posts crossed, will read your post shortly.

Ron

Emgee07/07/2020 11:05:59
1541 forum posts
219 photos

Ron

Nice looking design for the remote control, did you fit the switches to the bottom of the enclosure so the lid and lid fixing screws are at the back of the picture posted ?

Emgee

Ron Laden07/07/2020 16:06:32
avatar
1970 forum posts
390 photos

Hi Emgee, I didnt make up the remote it is how it came done by the previous owner of the lathe but yes the switches are fitted to what would be the bottom of the enclosure and the lid and fixing screws are on the back.

Ron

Ron Laden08/07/2020 06:38:23
avatar
1970 forum posts
390 photos

I tested the pot on the remote it's a 10k but it read 3.1k..? 3.1 one side 2.75 the other. Checking the voltage 0 to 10.4 volts not understanding enough about it is that good or bad..? Operating the pot it didn't have any open spots.

I am thinking should I replace the pot regardless and at least know that any problem there is eliminated.

Ron

Stuart Bridger08/07/2020 07:59:24
455 forum posts
26 photos

Ron,

Can you control the speed from the front panel of the VFD? That should rule the pot in or out of the problem.

SillyOldDuffer08/07/2020 09:15:34
5924 forum posts
1281 photos
Posted by Ron Laden on 08/07/2020 06:38:23:

I tested the pot on the remote it's a 10k but it read 3.1k..? 3.1 one side 2.75 the other. Checking the voltage 0 to 10.4 volts not understanding enough about it is that good or bad..? Operating the pot it didn't have any open spots.

I am thinking should I replace the pot regardless and at least know that any problem there is eliminated.

Ron

Within reason the ohmic value of the 10k pot isn't critical for this application - good chance a 2k pot or a 20k pot would work equally well.

The pot is just a voltage divider. With the wiper fully anti-clockwise it puts zero volts on the VFD's speed control terminal, fully clockwise it should put 10.4V on the VFD. May be a two man job but measure how the volts change at the VFD terminals (VFD end of the pot ground and wiper wires.) If the voltage varies between 10.4 and 0 at the VFD, the pot is innocent.

If the pot tests OK I don't recommend changing it (or anything else). Swapping components risks introducing new problems, so I prefer not to do it until a test suggests it's worth doing. Diagnosing is mostly logical, best not to change things at random.

Can you post a list of exactly what works and what doesn't? (There's a danger of the forum fixing stuff that isn't broke!)

At the moment the goal is to make sure the wiring, switches and pot are all OK and doing what they should at their respective VFD terminals. The control signals from the pendant are usually simple, ON, OFF apart from the pot, which is a voltage between 0 and 10.

Once satisfied the wiring is OK, next step is to check the VFD settings. There are a multitude of these, but - if the problem is only the speed range - it should be possible to identify what's adrift. Possibilities: minimum motor speed, pot control range, frequency - we'll need a Jaguar manual and with luck another owner or expert will help understand it.

As the VFD is turning the motor, I think it unlikely its electronics are damaged, or there's a wiring problem between VFD output and the motor, or with the motor itself. More likely, it's in the control wiring and/or the VFD settings.

Electronics are generally very robust and reliable, but there are weaknesses. Many components are intolerant of being taken outside their ratings, even briefly, and go pop. Computers are sensitive to environmental disturbances - getting too hot, voltage spikes, brownouts, and the solar wind. They're also vulnerable to illogical inputs as might be caused by a faulty ground wire causing a fast stream of random input changes. And to people mistakes.

Whatever the cause, if the VFD's had a nervous breakdown and the settings are garbled, it's just a matter of wading through and putting them right. A Jaguar owner who's already done this would be a godsend!

Dave

fastdave08/07/2020 09:50:00
avatar
28 forum posts

I'm with Dave on this one, really, but Let's localize the fault, to use one of the most worthwhile phrases in faultfinding.

Can you connect the motor straight into the VFD? It's just a matter of U,V and W connections from where they are just now, straight into the box - there are several ways of connecting, from terminal strip to ring terminals, but the essence is still U,V,W. - Since the VFD seems to run without the motor (I think I got that right), I am becoming very suspicious of the motor. Can you get to the terminals, disconnect and put an Ohmmeter across each winding? they should be about the same.

If you live near me, I'll do it for you - if you are not confident, grab an electrical pal who knows his stuff - if you solve it in the meantime, - Well done!.

Dave, Fife.

fastdave08/07/2020 09:52:49
avatar
28 forum posts

Ron, I've tried in the past, adjusting IF coils on a radio, to find I made things worse, and the fact was that no - one had adjusted them at all, it was much more basic - cost me an RF generator (costly item).

We may be barking up the wrong tree with the settings.

Dave, Fife.

David Davies 808/07/2020 10:50:01
avatar
112 forum posts
8 photos

"Now when I power up the VFD I get a reading of 0.00 but there seems to be no communication between VFD and the remote control panel, fwd/rev switches, the on/off switches and the speed control pot are all doing nothing."

Ron

Check the following parameters on the VFD or compare with any written setup data that you were given with the machine.

F01 Frequency command =1 , this enables voltage input to terminal 12.

F02 Run/Stop/Direction. =1, this enables external Fwd/Rev

F03 Max Frequency = 50.0, this is a basic setting , you may wish to increase but then you are into field weakening

F04 Base frequency = 50.0, (this should be set as the figure given on the motor rating plate)

F16 Minimum frequency = 10.0, not too low, when running slowly the fan is non-effective

taken from Cub handbook pages 5-3 and 5-4.

HTH

Dave, yes, another one.

Edited By David Davies 8 on 08/07/2020 10:50:42

Ron Laden09/07/2020 06:17:01
avatar
1970 forum posts
390 photos

Good news, problem fixed lathe back to normal.

I wondered what after sales support would be like from the UK supplier of the VFD (Transwave) so gave them a call. Well it couldn't have been better their technical support guy couldn't have been more helpful must have been talking it through for 20 minutes. His thoughts were that the ground cable becoming disconnected at the remote speed pot had upset something in the VFD.

He sent me an email on how to quickly and easily get all the settings back to the factory defaults and then how to set it up. Followed his guide and fault fixed.. yes

​​​​​Thanks guys for your advice though fortunately the support from the supplier saved me having to delve too far.

Ron

 

Edited By Ron Laden on 09/07/2020 06:26:42

fastdave09/07/2020 09:15:52
avatar
28 forum posts

Brilliant - we all heave a sigh of relief - What a good end to a problematic week!

Dave, Fife.

Ian P09/07/2020 11:34:58
avatar
2406 forum posts
101 photos

Did the procedure in the guide cover the same information that was suggested in the replies in this thread?

Whether it did or not, purely on a 'dont need to know' basis, I and others would like to know what the actual cause was?

Ian P

john fletcher 109/07/2020 12:20:28
601 forum posts

Hello Ron, is it possible for you to post a copy of the email from transwave here for other person possible use in the future, one never knows. John

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of Model Engineer or Model Engineers' Workshop? Use our magazine locator links to find your nearest stockist!

Find Model Engineer & Model Engineers' Workshop

Latest Forum Posts
Support Our Partners
Warco
ChesterUK
Eccentric July 5 2018
EngineDIY
Allendale Electronics
cowells
emcomachinetools
Eccentric Engineering
Subscription Offer

Latest "For Sale" Ads
Latest "Wanted" Ads
Get In Touch!

Do you want to contact the Model Engineer and Model Engineers' Workshop team?

You can contact us by phone, mail or email about the magazines including becoming a contributor, submitting reader's letters or making queries about articles. You can also get in touch about this website, advertising or other general issues.

Click THIS LINK for full contact details.

For subscription issues please see THIS LINK.

Digital Back Issues

Social Media online

'Like' us on Facebook
Follow us on Facebook

Follow us on Twitter
 Twitter Logo

Pin us on Pinterest