By continuing to use this site, you agree to our use of cookies. Find out more
Forum sponsored by:
Forum sponsored by Allendale Dec 6th

Miitutoyo caliper error

All Topics | Latest Posts

Search for:  in Thread Title in  
BOB BLACKSHAW21/09/2019 17:53:08
235 forum posts
51 photos

I have a old Mitutoyo DIGIMATIC calliper which must be 25 years old, it packed up quite a few years ago, so finding it again in the shed is it repairable.

When installing the battery a very dim E comes up, and that's about it, I must state that the E is just about recognizable.

If its no good then a single parallel can be salvaged, but chopping the calliper up seems criminal as its so smooth to use.

Bob.

old mart21/09/2019 18:46:00
785 forum posts
77 photos

If you go on the Mitutoyo website, they sell spares, but you need to register before getting the full information. I bought part of the electronics of a digital mike from them about 7 years ago, with great success. Check the voltage of the battery, it should be 1.5V.

Vic21/09/2019 18:59:02
2330 forum posts
12 photos

As it’s very dim are you sure it’s an E? Mine comes up with B when the battery is low.

BOB BLACKSHAW21/09/2019 22:13:23
235 forum posts
51 photos

Its a new battery and still hard to make out the E.

JohnF21/09/2019 23:09:45
avatar
884 forum posts
114 photos

Not impossible for a new battery to be a dud ! try it in another tool or a different battery first, also are the contacts clean with no corrosion ? Stating the obvious but !!!!

Brian G22/09/2019 08:33:23
613 forum posts
25 photos

According to this Practical Machinist Link "E" could mean the scale needs cleaning, but like the others, if it is faint I would first suspect the battery.

Brian

BOB BLACKSHAW22/09/2019 08:48:33
235 forum posts
51 photos

I will try another battery later to day if I have one, but I did notice the terminal the negative --- looks like its been arcing on the terminal.

Diogenes22/09/2019 08:53:41
37 forum posts
6 photos

I have paper instructions here.. .."E" does indeed mean the scale needs cleaning - the instruction say to clean the scale, and if the "E" error message still remains, it is necessary to then remove and re-install the battery.

If still no go, I would try disassembly and cleaning the inside "track reading" area of the head unit before I consigned it to the scrap bin..

Hope this helps

D

Michael Gilligan22/09/2019 09:05:49
avatar
14244 forum posts
627 photos
Posted by BOB BLACKSHAW on 22/09/2019 08:48:33:

I will try another battery later to day if I have one, but I did notice the terminal the negative --- looks like its been arcing on the terminal.

.

Bob,

May I just ask exactly what batteries you use ?

I may be reading too much into your statement [in which case, please forgive me], but it sounds like you might have 'stock' ...

MichaelG.

.

Edit: I've just searched  back on this forum ... Almost six years ago, I wrote:

I use Energizer 357/303 Silver Oxide in my Mitutoyo caliper.

... Long shelf life, and excellent performance. [*]

Using cheap Alkaline cells in good equipment is a false economy.

.

Ref. https://www.model-engineer.co.uk/forums/postings.asp?th=88252

Edited By Michael Gilligan on 22/09/2019 09:19:19

BOB BLACKSHAW22/09/2019 09:12:58
235 forum posts
51 photos

The battery is a AG13, the sort I've got are a multipack button cell, I've used them on my height gauge an seem to work ok.

They are not the best quality.

Michael Gilligan22/09/2019 09:27:06
avatar
14244 forum posts
627 photos

Thanks, Bob

My edit crossed with your reply ... but I think we may be onto something:

Have a look at the Voltage Duscharge curves on this page, that I've literally just found on the web:

**LINK** http://www.lr44batteryequivalent.org/

MichaelG.

BOB BLACKSHAW22/09/2019 10:26:31
235 forum posts
51 photos

Thanks for the link Michael, well worth getting a silver oxide battery and try it.

I will let you know on this post.

Thanks all, Bob.

BOB BLACKSHAW25/09/2019 18:48:49
235 forum posts
51 photos

I put the new silver oxide battery in today but its still showing a very faint E symbol, so it looks like its finished as a calliper.

Bob..

Michael Gilligan25/09/2019 18:51:15
avatar
14244 forum posts
627 photos

Sorry to hear that, Bob

MichaelG.

Ron Laden25/09/2019 20:29:53
avatar
1451 forum posts
256 photos

Bob, I have a Mitutoyo Digimatic which is well over 30 years old and it still works but I do have to nurse it along. My problem is battery related also, I have to keep cleaning the contacts or the display dims even with a new battery fitted. Also the central contact which is angled upwards has lost its spring so I have a thin washer between the battery and battery cover to maintain contact.

Have you thought of giving the Mitutoyo service dept a call, I have been meaning to but havnt got around to it yet. They may have a standard charge for repair/service of their products, but it may also be a case of replacement parts plus an hourly rate and other charges which costs more than the calliper is worth.

I will have to look into it as I would like to keep it going, its till very nice to use and head and shoulders above the cheapo versions.

Grindstone Cowboy25/09/2019 20:45:46
139 forum posts
1 photos

Just for reference, here is a link to their website, which states " Direct end user contact is encouraged on spares/repairs to enable prompt, cost effective service and communication. A dedicated customer support telephone team is always on hand for assistance, you can call them on 01264 353123. "

BOB BLACKSHAW05/11/2019 17:59:38
235 forum posts
51 photos

dscn1130.jpgTried allsorts of batteries with no success, but this works a treat, tried and tested.

Bob

Michael Gilligan05/11/2019 18:12:59
avatar
14244 forum posts
627 photos

Nice big display too, Bob

... Every cloud has a silver lining yes

MichaelG.

Neil Wyatt05/11/2019 18:29:03
avatar
Moderator
16740 forum posts
689 photos
76 articles
Posted by BOB BLACKSHAW on 05/11/2019 17:59:38:

dscn1130.jpgTried allsorts of batteries with no success, but this works a treat, tried and tested.

Bob

Aldi body?

not done it yet05/11/2019 18:39:31
3556 forum posts
15 photos

I somehow disbelieve the negative terminal has been arcing. 1.5 volts doesn’t do that trick too well. Corrosion is, by far, more likely. That could mean a high contact resistance, so much less voltage across the electronics than required.

All Topics | Latest Posts

Please login to post a reply.

Magazine Locator

Want the latest issue of Model Engineer or Model Engineers' Workshop? Use our magazine locator links to find your nearest stockist!

Find Model Engineer & Model Engineers' Workshop

Latest Forum Posts
Support Our Partners
emcomachinetools
Eccentric July 5 2018
Tee London LMES 6th Dec
Warco
Ausee.com.au
Allendale Electronics
Eccentric Engineering
ChesterUK
cowells
Subscription Offer

Latest "Wanted" Ads
Get In Touch!

Do you want to contact the Model Engineer and Model Engineers' Workshop team?

You can contact us by phone, mail or email about the magazines including becoming a contributor, submitting reader's letters or making queries about articles. You can also get in touch about this website, advertising or other general issues.

Click THIS LINK for full contact details.

For subscription issues please see THIS LINK.

Digital Back Issues

Social Media online

'Like' us on Facebook
Follow us on Facebook

Follow us on Twitter
 Twitter Logo

Pin us on Pinterest