By continuing to use this site, you agree to our use of cookies. Find out more

Member postings for Nicola Casali

Here is a list of all the postings Nicola Casali has made in our forums. Click on a thread name to jump to the thread.

Thread: Issue jogging in 0.001mm steps in Mach3 with Sieg KX3
10/06/2021 17:26:01

JasonB, could there be something in my Mach3 XML file that is causing Y to behave differently? Or could it be a stepper driver issue?

10/06/2021 17:03:32

Copying JasonB and using the mouse to jog any axis, all axes change the Mach3 DRO by -0.002mm, as long as it's negative. I can't get any DRO axis to change positively or steppers to move. The X+, Y+ and Z+ buttons do nothing.

The X-, Y- and Z- buttons change the DRO by 0.002mm, on alternate mouse clicks. The X and Z axes steppers also appear to move the carriage or column by 0.002mm on alternate clicks, but haven't measured but can hear. The Y stepper doesn't do anything, despite the DRO changing.

It's not keeping track of Y in machine space. Why not? Yes, it's a Y axis problem again.

Edited By Nicola Casali on 10/06/2021 17:04:20

Edited By Nicola Casali on 10/06/2021 17:05:06

10/06/2021 15:49:44

Ok, so jogging in 0.001mm steps doesn't appear to move my Y axis, despite the DRO incrementing and decrementing by that amount. That's using the arrow buttons on my keyboard. Moving in those increments is not practical, anyway, right?

But my iMach P4-S pendant does use 0.001mm (actually it's 0.002mm) steps in velocity mode, when moving the wheel slowly or at the beginning (or end) of an acceleration when getting up to speed in velocity mode. [edit: I assume it's using those microsteps anyway between point A and B] When moving the wheel slowly, I note that I can change the DRO and not get any stepper motor motion. Also, doesn't that affect g-code too?!

Anyone have any ideas what's going on with jogging very small steps? How do I prevent the DRO from changing when no steps are being output to the stepper motors?sad

Edited By Nicola Casali on 10/06/2021 16:01:41

Thread: Further Adventures with the Sieg KX3 & KX1
22/05/2021 16:16:44

I've tried tabs, but got some nasty vibrations with my non-centre cutting endmills. I don't think it's ramping into those tabs, for some reason. I tried triangular ones.

Edited By Nicola Casali on 22/05/2021 16:17:48

22/05/2021 15:59:09

Sorry, I was referring to https://youtu.be/HWVk5nqtSXc

I just realised I used F360 for the flanges. I may have attempted Aspire first. The stock is 6.35mm. I was using a 1mm stepdown with a 4 flute endmill. I'll try your suggestions, as I need to make 3 more. Great!

 

Edited By Nicola Casali on 22/05/2021 16:00:45

22/05/2021 14:03:13

I made these a few weeks ago with Aspire, before I got started with F360 CAM. I had to go really slow with multiple depths and used lots of coolant.

JasonB, I can see your contouring above is quite slow too. What depth of cut are you taking?


I tested some contouring with F360 a few days ago with no mist or coolant and got my 6mm carbide bit to glow wonderfully. My feeds and speeds were massively optimistic. Cutting a slot in steel is a completely different ball game, obviously.

Stock workholdingFlange contouringFlanges

Thread: Sieg KX3 Y_Axis Skipped Stepper Steps😢
10/05/2021 00:57:56

Didn't have time to look at the replies as I was machining the pieces. All done. But did have trouble with my Warco vice lifting when holding stock on the last couple of millimetres of the jaws. My toolmakers vice was even worse. I managed to minimise it by hammering the stock down, as recommended in other threads. If there's a vice that doesn't lift, please suggest one.

Machining vertically would have been much simpler. Simpler setup and just one step. I don't have a 25mm long carbide endmill at this moment. That's one amazing project you've got going there with that engine.

I've always been nervous about loading the cutters too much. But the carbides were cutting as if they were tackling aluminium or even hardwood. That's given me a lot more confidence. I really appreciate the help to sort out my machine and all the advice.face 1

08/05/2021 19:01:47

Great job! Now, how did you get scallop to do one side at a time? Mine's doing a column at a time and then going to the other side, back and forth. Lots of time wasted.

 

[edit] Got it. I unselected the top face and it seems to be doing something similar to yours.

Where did you get those lovely wavy parallels from? I definitely need those!

Edited By Nicola Casali on 08/05/2021 19:04:09

Edited By Nicola Casali on 08/05/2021 19:06:06

07/05/2021 15:10:34

I'm being overcautious with the noise. I have time after 7pm to do milling. I continue until 10:30pm. Outside my garage I can hear surprisingly little. But I've no idea how well the low frequency vibrations transmit through walls. It just sounds loud in the garage with the noise reflecting off bare walls.

I'm not sure why I am using larger diameter cutters for this job. I do have 6mm carbide flat endmills. I have a load of 12mm HSS ones I bought a while back and just went with those for this job. I'll try the 6mm ones with a higher rpm. That could make the difference. I did not think about that. Thanks.

07/05/2021 13:26:22

I'm only machining a part of the extrusion. About 25mm at a time and then cutting the machined piece off and starting again. i need about 16. I can't work out how to clamp the whole length without collision, so I'm using a vise with a chunk sticking out. Not ideal. I'm using whatever scrap metal I found in my cupboard to mill from. But it distorted along the length after cutting on my bandsaw, anyway.

I've received some carbide ball endmills from Arc. But I'm going to continue using the HSS one until it's dull. Not sure I can sharpen ball endmills with any accuracy that's worth the pain though. I do sharpen flat ones on a universal grinder.

Edited By Nicola Casali on 07/05/2021 13:27:27

07/05/2021 12:30:49

JasonB, i thought I was looking at my machine for a second. There's a bit of cardboard to stop the vibrations just like on mine. I have them also stuffed in the main enclosure. The enclosure seems to amplify all the noise. My machine is up against a single brick thick party wall in an attached garage.

For the F360 job, I'm setting up the DTI so that it reads 0 when Mach3 reads -30.0000 mm in Y. After the job I jog the Y until the DTI reads zero again and check the Mach3 Y readout. It would show -29.7500 mm, for example.

Actually, I had to cave in and purchase a year F360 subscription. I have so many components being used at once. I was using Aspire, but mostly for 2D milling and engraving. I've moved to F360 cam. Might as well since I'm paying for it now. And the designs move seamlessly into the cam module.

I see now. There's lots of rapids. I was looking at G0 Z5. and not realising the subsequent lines were rapid moves too.

I checked the rapid speeds in Mach3. It was set to 1999. One of those settings I was messing about with a few months back and forgot to set back. It will have worked fine in X, but would be on the edge of failure for Y. My little vise seems to have pushed it over that edge. The first component I produced was clamped without a vise. But some heavy cuts were causing sliding. Once I attached the vise I lost accuracy. That first component produced so perfectly was confusing me. What had changed?!

I'll double check after running the job again (with JasonB's update), but hope that's the problem fixed. But thanks for all your invaluable input. I'll update soon.

 

[edit] Forgot to say I ran the job cutting air and there were no missed steps.

Edited By Nicola Casali on 07/05/2021 12:45:47

07/05/2021 02:36:30
Posted by John Haine on 06/05/2021 13:32:01:

Have you tried moving the table back and forth along the Y axis using G code via the MDI? If you typed in -

G91 (sets incremental mode)
F100
G1 Y10
G1 Y-10
G1 Y10
G1 Y-10

...while checking the motion with a DTI it should always return to the same point at either end of the travel.

I put this in a loop in a text file and ran it 200 times at F250. It didn't skip a single step, or didn't accumulate lost steps. I jogged the Y axis back and forth with my pendant a dozen times. No steps lost. I didn't rerun the F360 file. This was 1:30am. I will try again tomorrow during the day, when whatever conditions may be playing a part...return? Mysterious.

06/05/2021 14:34:49

Nice simple test. Will try soon. I don't think I tried that one yet. Although I have written a loop in g code that does something similar, but in absolute mode. That loses steps. I have tried moving the table back and forth using a Vista pendant with the wheel with a variable velocity. That loses steps too.

06/05/2021 13:02:18

JasonB, when the dial indicator I set up is indicating zero, the ball screw has returned to its mark. However, in Mach3 readout it's off by 0.25mm. To me that means the ball nut is fine, at least.

06/05/2021 11:12:45

JasonB, I have marked the ballscrew and it returns to the correct place when the table hits the dial indicator I've set up. And thanks for the view of the stepper drivers.

This is actually my first attempt at 3D machining with Fusion 360. I'm thinking about rotating the model and stock by 90 degrees to see if X starts getting affected.

Joseph, here's the file.
https://www.filemail.com/d/zgorgrgcozwfvti

Edited By Nicola Casali on 06/05/2021 11:16:04

06/05/2021 01:42:07

Reversing the Y axis causes it to lose steps in the opposite direction by the same amount. Let me sleep on it..crook

06/05/2021 00:26:07

I checked for backlash. There appears to be about 0.02mm.

I did check the ball nut. I checked it as I unbolted it to see if there was any binding in the tapered gib. I tightened it back up really well. It appears to be a consistent step loss in one direction only. Bizarre! I can reverse the direction of Y travel in Mach3. That's what I'll do next. That'll confuse it..laugh

05/05/2021 23:37:14

Job finished. Y is off by -0.25mm. This was with 10us pulses and 200 acceleration. Tomorrow I'll take a look at the stepper drivers and compare any settings. If they are identical I'm going to swap the X and Y and retest.

05/05/2021 23:22:24

Swapping parallel ports on the UC300Eth did not help.

I never did set up UCCNC in the end, despite having a license. I'm still using Mach3.

I don't know which drivers are being used or dip switches. The machine is set up against a wall and access is from the back. I did manage to fit wheels to the base, so I am able to move it and check those things out. It's quite a hefty machine though.

I've now gone for your suggested 10us pulses and started a job without stock. I've reduced the acceleration for Y from 300 to 200 in Mach3. With 5us pulses that didn't make any difference. Let's see with the 10us pulses.

Actually, the table is gradually moving away from me, meaning it's having problems 'moving' the spindle in the + direction.

The only rapids are once at the start and then rapids only for z throughout.

Currently, I only have a small 70mm vise bolted to the work table.

05/05/2021 21:32:08

I disconnected the lead screw nut for the Y axis and moved the table by hand. There doesn't seem to be any binding in any direction. I'm not sure how tight the tapered gib should be, but it's not loose.

It's not a machine I built. I purchased the KX3 new in 2011. I don't _think_ I've had this problem before. It could be a problem with the UC300Eth motion controller I installed in 2017.

I may have to limp along for now with accuracy in only 2 dimensions. The parts I need to machine only require that.

What I could try immediately is:

1. switch to an unused parallel interface on the UC300Eth.

then

2. swap the x and y pins on the breakout board.

3. swap the x and y stepper drivers to see if it's a driver issue.

4. swap around the stepper motors?

5. switch back to using an old Windows XP PC with parallel port to rule out UC300Eth. (I was about to dump that old PC)

6. ?

Magazine Locator

Want the latest issue of Model Engineer or Model Engineers' Workshop? Use our magazine locator links to find your nearest stockist!

Find Model Engineer & Model Engineers' Workshop

Support Our Partners
Warco
cowells
emcomachinetools
JD Metals
Eccentric July 5 2018
rapid Direct
walker midge
Eccentric Engineering
Subscription Offer

Latest "For Sale" Ads
Latest "Wanted" Ads
Get In Touch!

Do you want to contact the Model Engineer and Model Engineers' Workshop team?

You can contact us by phone, mail or email about the magazines including becoming a contributor, submitting reader's letters or making queries about articles. You can also get in touch about this website, advertising or other general issues.

Click THIS LINK for full contact details.

For subscription issues please see THIS LINK.

Digital Back Issues

Social Media online

'Like' us on Facebook
Follow us on Facebook

Follow us on Twitter
 Twitter Logo

Pin us on Pinterest